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Die vorliegenden Unterlagen sowie die Hard- und Software sind Ent-
wicklungen der Karl E. Brinkmann GmbH. Irrtum vorbehalten. Die Karl E.
Brinkmann GmbH hat diese Unterlagen, die Hard- und Software nach
bestem Wissen erstellt, übernimmt aber nicht die Gewähr dafür, daß die
Spezifikationen den vom Anwender angestrebten Nutzen erbringen. Die
Karl E. Brinkmann GmbH behält sich das Recht vor, Spezifikationen
ohne vorherige Ankündigung zu ändern oder Dritte davon in Kenntnis zu
setzen.
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The documentation as well as the hardware and software are
developments of the Karl E. Brinkmann GmbH. Errors and ommissions
excepted! The Karl E. Brinkmann GmbH has prepared the documentation,
hardware and software to the best of their knowledge, however, no
guarantee is given that the specifications will produce the benefits aimed
at by the user. The Karl E. Brinkmann GmbH reserves the right to change
the specifications without previous notice or information to any third
parties.
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Allgemeines

Der KEB-Protokollmonitor ist eine PC-Software zur Darstellung und
Analyse von seriellen Telegrammen der KEB-Protokollfamillie. Die
Software läuft unter WIN95/98/NT und benutzt eine serielle Standard-
schnittstelle des PC’s zum Empfang der Telegramme. Die eingehen-
den Zeichen werden je nach eingestelltem Protokoll ausgewertet und
zeilenweise dargestellt. Da hierbei Telegrammanfrage und Antwort
auf einer physikalischen Empfangsleitung liegen, müssen diese zeit-
lich hintereinander ohne Überschneidung vorliegen (Kein Voll-
duplexbetrieb möglich).

Dies ist beim DIN66019II-Protokoll gewährleistet, im HSP5-Operator-
modus sorgt der angeschaltete Feldbusoperator für die Einhaltung des
zeitlichen Ablaufs. Die erkannten Telegramme können gespeichert
und wieder geladen sowie in die Windows-Zwischenablage zur Ver-
wendung in anderen Programmen kopiert werden.

Es ist auch eine Schicht-7-Dekodierung zur Darstellung der
Parameterwerte in normierter Anzeige und eine Filterung/Triggerung
auf spezielle Telegramminhalte möglich.

1. Allgemeines

Beispiel aufgezeichneter
HSP5-Telegramme
mit eingeschalteter

Schicht-7-Dekodierung
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For a later evaluation the stored telegrams can be written into a file by
means of menu option ‘File->Save’. Stored telegrams are loaded
again over the menu option ‘File->Read’. In that case the telegrams
displayed so far are lost.

To search for certain telegrams set the filter accordingly and place the
selection bar on the telegram entry, where the search shall begin.

Press STRG+F to start the search in the direction of ascending tele-
gram numbers. If a suitable telegram is found the selection bar is set
on it.

If you want to stop the recording upon the occurrence of a certain
event, proceed as follows:

To prevent the storing of too many telegrams after the triggering you
can specify the maximal number of the recorded telegrams by means
of menu option ‘Settings->Max buffer’. On exceeding this number the
oldest telegrams are overwritten. Set the filter now according to the
event. By means of menu option ‘Filter->Trigger’ or key F4 the
triggering is activated and the number of the following telegrams still to
be recorded is determined. Start with F9 or the start icon. Upon
recognition of the desired telegram the recording, if necessary after the
telegrams that still follow, is stopped and a reference is output.

3.5 Search

3.6 Triggering on
certain telegrams

3.7 Storing / Reading

Program Operation
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Betriebsarten

2. Betriebsarten Der KEB-Protokollmonitor kann für verschiedene Betriebsarten und
Anwendungsfälle genutzt werden:

In dieser Betriebsart werden eingehende DIN66019II-Telegramme
z.B. vom Feldbusmonitor aufgezeichnet. Das DIN66019II-Protokoll
enthält neben den erweiterten Diensten auch die altbekannten Tele-
gramme des DIN66019-Protokolls. Klicken Sie auf den DIN66019II-
Protokoll-Knopf und wählen Sie die gewünschte Schnittstelle und
Baudrate aus. Das Zeichenformat (7 Datenbits, 1 StoppBit, gerade
Parität) wird automatisch übernommen. Starten Sie die Aufzeichnung
mittels dem Start-Knopf links oben oder über die Taste F9. Die Anzahl
der empfangenen Telegramme wird in der Liste links oben angezeigt.
Die erkannten Telegramme werden in die Liste eingetragen. Zum
Stoppen betätigen Sie den Knopf links oben oder die Taste F9 erneut.

2.1 Betrieb als
DIN66019II-Monitor

2.2 Betrieb als HSP5-
Monitor für Feld-
busoperatoren

In dieser Betriebsart wird die Schnittstelle des PC’s über ein HSP5-
Adapterkabel nebst Adapter auf Western-Stecker an die Diagnose-
schnittstelle einen F5-Feldbusoperators angeschlossen.

ACHTUNG:
Niemals die PC-Schnittstelle ohne spezielles Adapterkabel an eine
HSP5-Schnittstelle anschließen! Dies hätte eine Zerstörung der PC-
Schnittstelle zur Folge.

Klicken Sie auf den HSP5-Protokoll-Knopf und wählen Sie die ge-
wünschte Schnittstelle und eine Baudrate von 38400 Baud aus. Das
Zeichenformat (8 Datenbits, 1 StoppBit, gerade Parität) wird automa-
tisch übernommen.

Wählen Sie zusätzlich die aufzuzeichnenden Funktionen rechts oben
aus:

• Comm: zeichnet Telegramme des Parametrierkanals
(PCP-Kommunikation/SDO-Kommunikation) auf.

• PD Out: zeichnet die OUT-Prozessdatentelegramme
(von der Steuerung zum Umrichter) auf.

• PD In: zeichnet die IN-Prozessdatentelegramme
(vom Umrichter zur Steuerung ) auf.
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For the representation of standardized parameter values and plaintext
for the services 0 and 1 (layer-7-decoder) a parameter file compatible
to COMBIBIS5 is necessary (PARAxxxx.bin, xxxx=inverter-software
number). By selecting the menu option ‘Settings->L7 decoder’ this
function can be activated and deactivated. If COMBIVIS5 is installed
on the PC, the protocol monitor finds the directory automatically.
Select the appropriate file to activate the layer-7-decoder.

3.2 Plaintext
representation

Entries into the telegram table can be copied as text into the window
temporary storage. Thus it is easily possible to use these in other
applications. The columns are separated by TABs, the lines through
line folding characters. Select the menu option ‘File->Copy’ or the
keys CTRL+C and enter the range of the telegrams. Maximal 1000
telegrams can be copied at the same time. In case of activated display
filtering all filtered telegrams (max. 1000) can be copied too.

To display only certain telegrams from the quantity of recorded
telegrams you can activate the setting dialog for the filtering conditions
by means of menu option ‘Filter->Set filter’ or the key F2:

With the setting ‘All’ one filtering condition fits for all telegrams. Furt-
hermore ALL filtering conditions must fit to an individual telegram in
order to select this telegram. This can result in the fact that NO tele-
gram can pass the filter. In case of doubt only one filter setting should
be tried out and the result checked. The filter setting for ‘Address’ is
only possible for requests with address specification, ‘ParameterData’
is intended for the services 0 and 1 (parameter value). Likewise
process data and scope telegram values are only possible for the
corresponding services, as the filtering condition will never be met for
other services!. The key OK closes the window and activates the
settings.

With key F3 the display can be filtered, i.e. only telegrams are
displayed that correspond to the filtering criteria. However, sometimes
also neighbouring telegrams are displayed to see for example the
preceding request when filtering on a negative acknowledgement.

3.3 Export into other
applications

3.4 Filtering

Program Operation
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Es ist auch eine beliebige Kombination der Funktionen möglich. Star-
ten Sie die Aufzeichnung mittels dem Start-Knopf links oben oder über
die Taste F9. Zum Stoppen betätigen Sie den Knopf oder die Taste F9
erneut. Die Anzahl der empfangenen Telegramme wird in der Liste
links oben angezeigt. Die erkannten Telegramme werden in die Liste
eingetragen.

Die Spalte ‘ID’ enthält eine fortlaufende Folge der Telegramm-ID-
Nummern im Bereich 01h bis 0Fh. Lücken in dieser Reihenfolge
bedeuten, daß der Operator die fehlenden ID’s wegen fehlender Buffer
nicht ausgeben konnte. Dies tritt häufig bei aktivierten PD-In-Funktio-
nen und schnellem Wechsel der IN-Prozessdaten auf, die im
Millisekundentakt vom Umrichter gelesen werden, jedoch über die
relativ langsame 38400-Baud-Verbindung zum PC nicht schnell
genug ausgegeben werden können.

Betriebsarten

In dieser Betriebsart können beliebige HSP5-Telegramme über die
serielle Schnittstelle des PC’s empfangen und dargestellt werden.
Aktivieren Sie hierzu den HSP5-Modus mit der gewünschten Baud-
rate, jedoch ohne Auswahl einer speziellen Monitorfunktion.

Es sind folgende Einschränkungen zu beachten:

1. Die HSP5-Schnittstelle zwischen dem Umrichter  KEB
COMBIVERT F5 und Operator hat keine PC-kompatiblen
Spannungspegel. Hierzu ist eine spezielle Hardware mit entspre-
chenden Pegelwandlern sowie eine Zusammenführung des Sende-
und Empfangskanals nötig.

ACHTUNG:
Einige Kontakte der HSP5-Geräteschnittstelle führen Spannungen
bis 30V. Ein direktes Aufschalten an den PC führt zur Zerstörung
der PC-Schnittstelle.

2. Zwischen dem KEB COMBIVERT F5 und den meisten Operatoren
werden keine PC-kompatiblen Baudraten gefahren. Eine Anzeige
dieser Formate ist somit nicht möglich.

3. Das HSP5-Protokoll ist ein Vollduplexprotokoll. Anfrage und Ant-
wort der Telegramme können sich überschneiden und eine sinnvol-
le Darstellung damit unbrauchbar machen.

2.3 Betrieb als generel-
ler HSP5-Monitor
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The telegrams are represented in tabular form one under the other.
With the aid of the scroll bar on the right or above the cursor keys, the
keys Up/Down and Beginning/End, the list can be scrolled. The left
column contains the telegram number, next to it the ID of the telegram
is displayed. The ID-numbers are sequential indications for the
allocation of response to inquiry. Telegrams of the old DIN66019-
protocol as well as special indications have no ID-number. The
column ‘Function/Service’ indicates the type as well as the used
service:

Req Read : Request reading, a value shall be read

Rsp Read : Response reading, the read value or an error code

Req Write : Request writing, a value shall be written

Rsp Write : Response writing, the acknowledgement to a write order

Select: Inverter addressing at DIN66019II-protocol.

The different services can be taken from the service description KEB-
Protocols and indicate the type of the service like e.g. writing the
parameter value or reading the parameter name etc.

In the column ‘Additional’ further service-specific details like e.g.
inverter address, parameter value or name and, in the case of
activated layer-7-decoding, also the standardized parameter value are
indicated.

With the key F12 or the menu ‘Settings->Hex Display’ the
representation of the parameter values can be changed from decimal
to hexadecimal.

By means of the menu option ‘File->Clear’ all telegrams can be
deleted after query.

Program Operation

3. Program Operati-
on

3.1 Representation of
telegrams
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Die Telegramme werden in Tabellenform untereinander dargestellt.
Mit Hilfe des Scrollbalkens rechts oder über die Cursortasten, die
Tasten Seite Auf/Ab und Anfang/Ende, kann in der Liste geblättert
werden. Die linke Spalte enthält die Telegrammnummer, daneben
wird die ID des Telegramms gezeigt. Die ID-Nummern sind fortlaufen-
de Kennzeichnungen zur Zuordnung von Antwort zur Anfrage. Tele-
gramme des alten DIN66019-Protokolls sowie Sonderanzeigen haben
keine ID-Nummer. Die Spalte ‘Function/Service’ zeigt die Art sowie
den verwendeten Dienst an:

Req Read : Anforderung Lesen; ein Wert soll gelesen werden

Rsp Read : Antwort Lesen; die gelesenen Werte oder ein Fehler-
code

Req Write : Anforderung Schreiben; ein Wert soll geschrieben wer-
den

Rsp Write : Antwort Schreiben; die Quittung auf einen Schreibauf-
trag

Select: Umrichteradressierung beim DIN66019II-Protokoll.

Die verschiedenen Dienste sind aus der Dienstbeschreibung KEB-
Protokolle ersichtlich und kennzeichnen die Art des Dienstes wie z.B.
Schreiben des Parameterwertes oder Lesen des Parameternamens
usw.

In der Spalte ‘Additional’ werden weitere dienstspezifischen Angaben
wie z.B. Umrichteradresse, Parameterwert oder Name und, bei akti-
vierter Schicht-7-Dekodierung, auch der normierte Parameterwert
angezeigt.

Über die Taste F12 oder das Menü ‘Settings->Hex Display’ kann die
Darstellung der Parameterwerte zwischen dezimal und hexadezimal
umgeschaltet werden.

Mittels dem Menüpunkt ‘File->Clear’ können alle Telegramme nach
Rückfrage gelöscht werden.

Programmbedienung

3. P r o g r a m m -
bedienung

3.1 Darstellung der
Telegramme
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Also possible is any combination of the functions. Start the recording
by pressing the start-icon on the top left or the key F9. To stop press
the icon or key F9 again. The number of received telegrams is
indicated in the list on the top left, the recognized telegrams are ente-
red into the list.

The column ‘ID’ contains a consecutive sequence of the telegram ID
numbers in the range 01h to 0Fh. Blanks in this series mean that the
operator could not output the missing IDs because of missing buffers.
This often occurs with activated PD in functions and rapid changes of
IN-process data, that are read from the inverter in millisecond steps but
which cannot be output fast enough to the PC over the relative slow
38400 baud connection.

Operating Modes

In this operating mode any HSP5-telegrams can be received and
represented via the serial interface of the PC. For that activate the
HSP5-mode with the desired baud rate, but without choosing a special
monitor function.

Following restrictions must be observed:

1. The HSP5-interface between F5-inverter and operator has no PC-
compatible voltage levels. A special hardware with the appropriate
level converter and a junction of the transmitting and receiving
channel are necessary.

ATTENTION:
Some contacts of the HSP5-unit interface carry voltages up to 30 V.
A direct connection to the PC leads to the destruction of the PC-
interface.

2. Between F5-inverter and most operators no PC-compatible baud
rates are driven. The display of these formats is therefore not
possible.

3. The HSP5-protocol is a full duplex protocol. Inquiry and response of
the telegrams can overlap thereby making a sensible representation
useless.

2.3 Operation as
general HSP5-
Monitor
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Zur Darstellung normierter Parameterwerte und Klartexte für die
Dienste 0 und 1 (Schicht-7-Dekoder) ist eine COMBIVIS 5-kompatible
Parameterdatei nötig (PARAxxxx.bin, xxxx=Umrichter-Software-
nummer). Durch Auswahl des Menüpunktes ‘Settings->L7 decoder’
kann diese Funktion ein- und ausgeschaltet werden. Ist COMBIVIS 5
auf dem PC installiert, so findet der Protokollmonitor das Verzeichnis
mit den Parameterdateien automatisch. Wählen Sie die passende
Datei aus, um den Schicht-7-Decoder zu aktivieren.

3.2 Klartextdarstellung

Einträge in der Telegrammtabelle können als Text in die Windows-
Zwischenablage kopiert werden. Damit ist es leicht möglich, diese in
anderen Anwendungen zu verwenden. Die Spalten werden hierbei
durch TAB's getrennt, die Zeilen durch Zeilenumbruchzeichen. Wäh-
len Sie den Menüpunkt ‘File->Copy’ oder die Tasten CTRL+C aus
und geben den Bereich der Telegramme ein. Es können maximal
1000 Telegramme gleichzeitig kopiert werden. Bei aktivierter An-
zeigenfilterung können auch alle gefilterten Telegramme (max. 1000)
kopiert werden.

Um in der Menge der aufgezeichneten Telegramme nur bestimmte
Telegramme anzuzeigen, kann über den Menüpunkt ‘Filter->Set filter’
oder die Taste F2 der Einstellungsdialog für die Filterbedingungen
aktiviert werden:

Mit der Einstellung ‘All’ passt einer Filterbedingung auf alle Telegram-
me. Weiterhin müssen alle Filterbedingungen auf ein einzelnes Tele-
gramm passen um dieses Telegramm auszuwählen. Dies kann dazu
führen, daß kein Telegramm den Filter durchläuft. Im Zweifelsfall
sollte zunächst nur eine Filtereinstellung versucht und das Ergebnis
geprüft werden. Die Filtereinstellung für ‘Address’ ist nur bei Requests
mit Adressangabe möglich, ‘ParameterData’ ist für die Dienste 0 und 1
(Parameterwert) vorgesehen. Prozessdaten- und
Scopetelegrammwerte sind ebenfalls nur für die entsprechenden
Dienste möglich. Bei anderen Diensten wird die Filterbedingung nie
erfüllt sein! Die Taste OK schließt das Fenster wieder und aktiviert die
Einstellungen.

Mit der Taste F3 kann die Anzeige gefiltert werden, d.h. es werden nur
Telegramme angezeigt, die den Filterkriterien entsprechen. Allerdings
werden manchmal auch benachbarte Telegramme mit angezeigt, um
z.B. bei Filterung auf eine negative Quittung auch den vorangehenden
Request zu sehen.

3.3 Exportieren in
andere Anwendun-
gen

3.4 Filterung

Programmbedienung
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Operating Modes

2. Operating Modes The KEB-Protocol Monitor can be used for different operating modes
and applications:

In this operating mode incoming DIN66019II-telegrams are for
example recorded by the field bus monitor. Besides the extended
services the DIN66019II-protocol also contains the well-known
telegrams of the DIN66019-protocol. Click on the DIN66019II-protocol
icon and select the desired interface and baud rate. The character
format (7 data bits, 1 stop bit, even parity) is taken over automatically.
Start the recording by pressing the start-icon on the top left or the key
F9. The number of received telegrams is indicated in the list on the top
left, the recognized telegrams are entered into the list. To stop press
the icon on the top left or key F9 again.

2.1 Operation as
DIN66019II-Monitor

2.2 Operation as HSP5-
Monitor for field
bus operators

In this operating mode the interface of a PC is connected over a
HSP5-adaptor cable with RJ-45 connector to the diagnostic interface
of a F5-field bus operator.

ATTENTION:
Never connect the PC-interface without a special adaptor cable to a
HSP5-interface! The destruction of the PC-interface would be the
result.

Click on the HSP5-protocol icon and select the desired interface and a
baud rate of 38400 baud. The character format (8 data bits, 1 stop bit,
even parity) is taken over automatically.

In addition to that select the functions to be recorded from the top right.

• Comm: Records telegrams of the parameterizing channel
(PCP-communication/SDO-comunication)

• PD Out: Records the OUT-process data telegrams
(from the control to the inverter)

• PD In: Records the IN-process data telegrams
(from the inverter to the control)
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Zur späteren Auswertung können die gespeicherten Telegramme über
den Menüpunkt ‘File->Save’ in eine Datei geschrieben werden. Ge-
speicherte Telegramme werden über den Menüpunkt ‘File->Read’
wieder geladen. Dabei gehen die bisher angezeigten Telegramme
verloren.

Zum Suchen nach bestimmten Telegrammen setzen Sie den Filter
entsprechend und platzieren den Auswahlbalken auf dem Telegramm-
eintrag bei dem die Suche beginnen soll.

Drücken Sie STRG+F um die Suche in Richtung aufsteigender
Telegrammnummern zu starten. Wird ein passendes Telegramm
gefunden, so wird der Auswahlbalken darauf gesetzt.

Wenn Sie beim Eintreffen eines bestimmten Ereignisses die Aufzeich-
nung stoppen wollen, gehen Sie wie folgt vor:

Damit nach der Triggerung nicht zu viele Telegramme gespeichert
sind, können Sie über den Menüpunkt ‘Settings->Max buffer’ die
Maximalzahl der aufgezeichneten Telegramme festlegen. Nach Über-
schreiten dieser Zahl werden die ältesten Telegramme wieder über-
schrieben. Setzen Sie jetzt den Filter entsprechend des Ereignisses.
Über den Menüpunkt ‘Filter->Trigger’ oder die Taste F4 wird die
Triggerung aktiviert und die Anzahl der noch nachfolgend aufzuzeich-
nenden Telegramme festgelegt. Starten Sie mit F9 oder dem Startkopf.
Beim Erkennen des gewünschten Telegramms wird, ggf. nach Ein-
gang der noch folgenden Telegramme, die Aufzeichnung gestoppt
und ein Hinweis ausgegeben.

3.5 Suchen

3.6 Triggerung auf
bestimmte Tele-
gramme

3.7 Speichern / Lesen

Programmbedienung
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General

The KEB Protocol Monitor is a PC-software for the representation and
analysis of serial telegrams of the KEB-protocol family. The software
runs under WIN95/98/NT and uses a serial standard interface of the
PC for the receipt of the telegrams. The detailed characters are
evaluated depending on the adjusted protocol and represented line by
line. Since telegran inquiry and response are on one physical receive
path, they must be present in temporal succession without overlapping
(full duplex operation is not possible).

 This is ensured with the DIN66019II-Protocol. In HSP5 operator mode
the turned on field bus operator provides for the adherence to temporal
sequence. The recognized telegrams can be stored and loaded again
as well as copied into the Windows-temporary storage for the use in
other programs.

A layer-7-decoding for the representation of parameter values in
standardized display and a filtering/triggering on special telegram
contents is also possible.

1. General

Example of recorded
HSP5-telegrams

with activated
layer-7-decoding
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